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FLASH2GUI Key Points 
 

 

Flash2GUI is written to support remote management of the SF2 and related products. It enables 

devices to be backed up, restored, taken online or offline (visible to the host), and changing the 

emulation presented to the host. 

On installation, Flash2GUI has a 30 day evaluation period and will prompt the user to request a 

license then apply it to the application. 

Flash2GUI supports usernames and passwords to guard against accidental execution of destructive 

commands such as erasing a drive. If the logged in user has the appropriate permissions though, 

destructive commands can be executed. Note this is not a protection against malicious behaviour. 

SF2 and related products are supplied with a default IP address of 192.168.1.44. If that is not 

appropriate for the network where the device is installed, this manual covers how to change that IP 

address. 
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Installation & Licensing 

Installation 
Flash2GUI is delivered as a single MS Installer file – Flash2GUI.msi. To install simply double-click on 

this file and you can run through a standard Windows installer. You have the option to change the 

location where the application is installed, and to control whether start-menu or desktop shortcuts 

are created. 

To uninstall, go through the MS Windows Add / Remove Programs control panel. 

Licensing 
The first time the product is run on a given machine, a 30-day evaluation period is activated. On 

startup you will see a dialog as below. 

 

This dialog will continue to be displayed on initial startup until a license is installed into the 

application. If the evaluation period expires before a license is applied, this dialog will continue to be 

displayed to allow you to add in a full license. If a full license is not added in (after expiration of the 

evaluation period) then the application will exit when this dialog is closed. Once a full license is 

applied this screen is not shown on startup but can be found under the File menu from the main 

screen. 

Full licenses are locked to individual hosts - you need a separate license from SSD for each host. 

In order to request a full license, click either ‘Send Email for License Request’ or ‘View Information 

for license Request’ and follow the instructions given. 
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Licenses are delivered as files and must applied by saving the file to your local disk then loading it 

using the ‘Load New License’ button. 

Once this machine is properly licensed, the license dialog will not be displayed on startup. It can 

always be viewed from the File -> License Status menu item, on a licensed machine this will show 

License Details button shows all of the relevant information for the licensing. 
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Usernames and Passwords 

Logging into Flash2GUI 
Flash2GUI employs a simple username / password scheme to control access to the application and 

the drives being controlled. After checking license status, the application displays the logon screen 

before allowing access to the main screen. Note that the intended usage of the usernames is around 

policy protection and reducing the likelihood of accidentally causing problems on the system. It is 

not appropriate for guarding against malicious behaviour. 

Enter the appropriate username and password here. 

Once you have logged on the application configures itself to disable any rights for which your 

username doesn’t have permissions. 

You can always change the logged in user through the File -> Change User menu item. 

Permissioning Levels 
When users are defined they are assigned a Level which controls what rights they have. There are 4 

defined user levels with increasing rights for administering the system 

Level Rights 

Level1 Backup 

Level2 As above plus Restore and Erase 

Level3 As above plus manage the connection list, manage the drive emulation, manage the 
write protection and take a drive offline / online as well as run the Image Manager 
to inspect the content of backups 

Administrator All rights which means as above plus manage users 
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Actions are greyed out on the application if a user does not have the appropriate permissions. So for 

a Level 1 user (backup only) the main window looks like this – with the Restore and Offline icons and 

the Drive menu greyed out. 

 

And the Connect window looks like this with the Save, Delete & Default buttons greyed out 
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Creating Users 
From the File menu on the main screen you can access the User Manager screen – assuming you are 

logged in as a user of the appropriate Level - and from that the form for defining new users. 

 

Note that the username / password information is local to the machine which Flash2GUI is running 

on – if Flash2GUI is installed on multiple machines then you need to create the usernames on each 

machine independently. 
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Connecting to the Drive 
Having logged in, a window appears to enable connection to the drive. 

 

The left box show the stored connections. Click on the required connection. The IP address and port 

number will be displayed on the right. To connect to the drive press the Save & Connect button. 

If the connection is a new one then fill in the IP address and port number and give the connection a 

name. Press Save & Connect. 

If the drive is a new one its IP and port number will be the factory default which is 

192.168.1.44:1024, you can connect to this device by just pressing the Default Connection button. 

If the drive is on a network which is not 192.168.1.xxx then the application can’t connect. See the 

section ‘Connecting to Factory Defaults’ on page 13 for instructions. 
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Creating & restoring backups 
When the application has connected to the drive the following screen is displayed. 

 

The box at the top left shows the status information for the drive. 

The buttons at the right show the main operations that can be performed. 

Take offline disables the host interface. 

To create a backup click on Create a Backup. 

A browser window will appear. 

Navigate to the folder where the backup file is to stored and give it a file name. The default name is 

Backup.bak. 

Click on Save to start the backup. 

A progress bar is displayed as the backup is taken. 

When the backup is complete a message box appears to confirm the backup completed successfully. 

Pres OK to continue. 

The procedure for restoring a backup is similar. 

Note that if a drive is write protected it is not possible to restore a backup or erase the drive. These 

options are greyed out to show they are not available. 
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Changing the network (IP) address. 
To change the Ethernet settings from the factory default, first connect to the drive. Then click on the 

Drive menu select NetworkSettings then Set Drive IP & Port. 

The following box then appears. 

 

Enter the new settings and give the connection a name. Click the Set button. 

The new settings are stored in the drive, the drive applies those settings and the application re-

connects using the new settings. 
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Connecting to Factory Defaults 
On delivery the drive IP address is set to the factory default of 192.168.1.44 and the port number is 

1024. 

Most internal LANs run with an IP address which lies between 192.168.0.0 and 192.168.255.255 

If your LAN is not set to 192.168.1.xxx you will not be able to connect to the SF2. 

To change the IP to an address which will work on your LAN you need to change your PC/laptop to a 

static IP address within the default settings of the drive. 

The exact way you do this is operating system dependent.  

For Windows 7 click on Control Panel , View Network Status & Tasks. You will then see the window 

below. 

Click on Change adapter settings to get the window below. This shows the networks on your 

computer. 

Right click on the network adapter to be changed and click on properties. A window as below will 

appear. 

Left click in TCP/IPv4 as shown and then click properties. 

To change to a fixed IP address click on Use the following IP address. 

Enter a suitable IP address which must start 192.168.1. the last number can be anything except 44 

and set the Subnet mask to 255.255.255.0 

Click OK. 

You will now be able to connect to the drive using the default IP address.  

Connect to the SF2 and using the procedure decribed in section 0 Changing the network (IP) address. 

Change the IP address to one that suits your LAN. 

Then follow the procedure above and reset the TCP/IPv4 settings to Obtain an IP address 

automatically. 
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Connecting to the SF2 over the Internet 
Using the FLASH2GUI application it is possible to connect to an SF2 over the internet. Firstly the SF2 

must be connected to the Internet router. Then port forwarding for port 1024 must be set up. 

Here is how this is done with the BT Home Hub. Not all routers will be setup the same, but this will 

help for configuring other routers. 

From the Home screen select Settings & Advanced Settings then Continue to Advanced Settings 

Select Home Network & Refresh. Now check the Physical connections for the connected SF2. This 

can be done easily if you know the MAC address (xx:xx:xx:xx:xx:xx). But if you don't, then you will 

need to click in each of the unknown connections until you find the correct device as identified by 

the IP address. 

Once you've found the device, enter a name (e.g. SF2) & Apply 

Now select Port Forwarding &Supported Applications then Add new game or application 

Fill in the Game/application name: (e.g. SF2) Port Range & Translate To boxes then Apply 

This will then appear in the User-defined games & Application list 

Now, to get access remotely you need to know you Internet router IP address. 

Select Broadband & the Broadband network IP address: is the router IP address 

So, from a remote location use the Broadband network IP address & the port number 1024 with the 

FLASH2GUI. 
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Preferences 
You can view the preferences for Flash2GUI using the File -> Preferences menu item. This shows 

where the loaded preferences file came from, whether there is a license key and allows the default 

network timeout to be overridden. 

 

Note that the preferences file needs to be created as part of the installation routine – if that file is 

corrupted or deleted you should revert to a backup of it or reinstall the software. If there is a 

problem loading this file on startup of the application an appropriate error message is displayed and 

the application fails to start. The preferences file is unique to a machine, you cannot take the 

preferences file from one machine and apply to a different machine. 

 

The default network timeout starts at 20 seconds and then gets overridden to 5 * the duration of the 

original connect process. As a general rule this should be sufficient for all cases however this timeout 

can be controlled through the preference s screen if necessary. 
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Drive Details 
Using the Drive -> Show Details menu, there is detailed version information available for the 

connected drive. Note that the contents of this window is dependent on the version of software 

running on the SF2 device. 
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Activity Logging 
There is very detailed logging of the activity between the Flash2GUI application and the connected 

disk drive, which is visible through the Help -> Messages menu item.  

 

This shows the last 5,000 lines of data transmitted between the GUI and the disk, and is primarily 

intended for debugging purposes. 

Note that this is only available for users with Admin level privileges. 
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Menu Items 

File 
Connect Connect to a different disk, or reconnect to the current disk 

Change User Relogin to Flash2GUI, allows you to change user (therefore permisisons) 

Image Manager Start the Image Manager to inspect the contents of backups from disks 

User Manager Allows you to manage the set of users defined for Flash2GUI 

License Status Show the license status and request or apply a permanent license 

Preferences Shows where the preferences are stored and modifies the network timeout 

Drive 

Set Size Shows a dialog box to switch the SF2 between emulating a specific device 
(therefore having that devices’ size), exposing the entire compact flash card to 
the host or setting a custom capacity in MB or Blocks (1 block = 512 bytes) 

Emulation Mode The SF2 has stored the set of devices it is capable of emulating. The list shown 
within Flash2GUI is dynamically built up by querying the SF2 and allows 
switching between different emulated devices. 

Set Online / 
Offline 

Toggle the SF2 online (visible to the SCSI host) and offline. This is the menu 
equivalent of the button on the main screen. 

Write Protect WARNING – this is not defined in the SCSI standard for fixed devices like hard 
disks. For removable devices this does the software equivalent of setting a 
write-protect switch. 

Backup Backup the SF2. Note that the button on the main screen will always backup just 
the size exposed to the host. As per the set-size menu item, the SF2 is capable of 
switching between an emulated devices size, the complete CF card size and a 
custom size. From the menu you can choose which of these to backup. 

Restore Restore the SF2 as per the button on the main screen. Restore will always 
restore the full set of data within the selected file. Flash2GUI will not check the 
size or type of emulated device the backup was created from against that 
currently configured on the SF2. Note that depending on the performance of the 
Compact Flash card this procedure can take a significant duration. 

Erase Erase the Compact Flash card. Again this allows you to select between erasing 
the Emulated Device, the complete Compact Flash card and the custom capacity 
defined on the SF2. Note that depending on the performance of the Compact 
Flash card this procedure can take a significant duration as it does a proper 
erase (writes to every byte on the CF card within the desired size). 

Network Settings Allows the IP Address, Port, Subnet Mask and Gateway on the SF2 to be 
changed. 

Refresh Status Updates the information Flash2GUI holds on the currently connected SF2. 

Show Details Gives additional version information on the connected SF2. 

Flash LEDs This will only be available connected to an SF2 running firmware at a version 
number greater than 1604.8. Executing this command will cause the red and 
green LEDs on the front of the SF2 to flash alternately for 30 seconds as a means 
to verify you are connected to the correct SF2. 

Get Trace Files This will only be available if the SF2 is running firmware which supports the 
tracing filesystem. If used it allows any trace files on that filesystem to be 
downloaded. 
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Clone This will only be available when connecting to an SF2 running as a fixed drive 
emulation (i.e. disk) and also running the SCSI Initiator firmware. Executing this 
will show a list of any other disks on the SCSI bus with the SF2, allowing you to 
select one other disk to copy the contents to the SF2. 

Execute 
Commands 

This will only be available when connecting to an SF2 running firmware later 
than 1774.9. This allows a user to enter a CLI command (as normally entered on 
the serial port) and execute that via Flash2GUI. Results will be shown in the pop-
up dialog from Flash2GUI. 

Get Emulation This will only be available when connecting to an SF2 running the SCSI Initiator 
firmware. Executing this will show a list of any other devices  on the SCSI bus 
with the SF2,allowing one to be selected. The SF2 will then execute a series of 
SCSI commands allowing SSD to then generate an emulation of that selected 
device. 

CmdSequence This causes Flash2GUI to read in a sequence of commands where each of them 
will be executed as per the Execute Commands menu option above. 

Help 
About Shows credits for this application and details where to find out further information 

Messages Gives a log of the most recent information transmitted between Flash2GUI and the SF2 
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Flash2Cmd Key Points 
Flash2Cmd is a command line utility shipped with Flash2GUI. It enables the disk drive emulators to 

be managed from a command line which has the advantage that it is possible to script processes. For 

example to have a regular backup every night you could use the Windows SCHTASKS process to run 

Flash2CMD with appropriate parameters. 
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Flash2Cmd Permissions 
Flash2Cmd follows the Flash2GUI permissions, therefore all Flash2Cmd calls need to include –u 

<username> -q <password> 

Usernames and passwords can only be administered from Flash2GUI. 

Note the password should be prefaced by a –q. 

See the examples following for how to use this. 
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Flash2Cmd Examples 

GetStatus 

 

GetVersion 
Example : flash2cmd 192.168.1.44 GetVersion -u admin -q xxxxxxxx 

Solid State Disks Flash2Cmd. Version 2.0.4.0  

INFO - Connecting to 192.168.1.44:1024 . . . 

INFO - Connected 

INFO - Firmware version: SF280_Ethernet Version E01.0044.1 

OK 

 

Example : 

Backup 
Example : flash2cmd 192.168.1.44 Backup -f d:\backup.bak -u admin -q 

xxxxxxxx 

Solid State Disks Flash2Cmd. Version 2.0.4.0 

INFO - Connecting to 192.168.1.44:1024 . . . 

INFO - Connected 

INFO - Drive Status 

        Online: False 

        CFCardPresent: True 

        Write Protected: False 

        Erase In Progress: False 

INFO - Drive is offline 

INFO - 512000 sector(s) of 512 byte(s) 

INFO - Drive is 262144000 byte(s) / 0.24Gb 

INFO - Drive Status 

        Online: False 

        CFCardPresent: True 

        Write Protected: False 

        Erase In Progress: False 

INFO - Backing up 262144000 byte(s) with a chunk size of 1024 byte(s) 

INFO - Saving backup to d:\backup.bak . . . 

INFO - 250.00mb of 250.00 (100.00%) in 173.07 second(s). 1479KB/s 

INFO - Backup completed in 173 second(s) 

OK 

 

Example : 
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Restore 
Example : flash2cmd 192.168.1.44 Restore -f d:\backup.bak -u admin -q 

xxxxxxxx 

Solid State Disks Flash2Cmd. Version 2.0.4.0 

INFO - Connecting to 192.168.1.44:1024 . . . 

INFO - Connected 

INFO - Drive Status 

        Online: True 

        CFCardPresent: True 

        Write Protected: False 

        Erase In Progress: False 

INFO - Drive online, taking offline . . . 

INFO - Drive Status 

        Online: False 

        CFCardPresent: True 

        Write Protected: False 

        Erase In Progress: False 

INFO - Drive is offline 

INFO - 512000 sector(s) of 512 byte(s) 

INFO - Drive is 262144000 byte(s) / 0.24Gb 

INFO - Drive Status 

        Online: False 

        CFCardPresent: True 

        Write Protected: False 

        Erase In Progress: False 

INFO - 250.00mb of 250.00 (100.00%) in 168.66 second(s). 1517KB/s 

INFO - Restore completed in 168 second(s) 

INFO - Putting drive online . . . 

INFO - Drive Status 

        Online: True 

        CFCardPresent: True 

        Write Protected: False 

        Erase In Progress: False 

OK 

 

Example : 
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Flash2Cmd All Commands and Options 
Note all commands need a –u <username> and –q <password> in order to run. Usernames and 

Passwords can be managed through the GUI application. 

Command Comment 

Backup Creates a backup from the drive, use –f to set the location 

Restore Restores a backup to the drive, use –f to set the location 

GetStatus Displays the status of the drive 

WriteProtectOn Software Write Protects the drive – equivalent of the WP tab on a floppy or 
tape but can also be set on hard disk emulations. 

WriteProtectOff Remove the software Write Protect from the drive – equivalent of the WP 
tab on a floppy or tape but can also be set on hard disk emulations. 

SetOnline Make the drive inaccessible to the host. 

SetOffline Makes the drive inaccessible from the host. Note backups and restores do 
an Offline before starting and an Online on completion to stop the host 
accessing the drive during the backup or restore. 

GetDriveSize Reports the amount of the card being used. Note compact flash cards 
always have 512 bytes per sector so if the emulated drive uses 256 or 768 
bytes per sector then the amount of the card being used will be greater 
than the drive size as exposed to the host. 

SetDriveSize DEPRECATED – use SetSize instead 

EraseCard Erases the whole compact flash card. Note this can be very time consuming 
however it does report progress. 

EraseCapacity Erases as much of the card as the host is using – this would normally be the 
same as EraseDevice unless a custom capacity has been set. 

EraseDevice Erases as much of the card as the currently emulated device would use as a 
default. 

GetEmulationModes Lists all the available drive emulations on the connected drive. 

GetEmulationMode Gets the detail for the current emulation mode on the connected drive 

SetEmulationMode Use –e to specify the emulation mode, using the ID from 
GetEmulationModes 

SetCapacity Sets the capacity mode, needs the –c flag to define the new mode (card = 
use whole card, device = default for the emulated device or custom = 
specified by SetDriveSize) 

GetCapacity Returns the current capacity mode (card = use whole card, device = default 
for the emulated device or custom = specified by SetDriveSize) 

SetSize Use –m for size mode and –k for size 

GetVersion Returns the version information from the drive 

GetIdentity Returns detailed information about the drive 

SetIPAddress Sets the Ethernet parameters, use –i for IP address, -j for IP port, -g for IP 
gateway and –l for subnet mask 

GetIPAddress Returns the Ethernet parameters on the drive. 

FlashLEDs Causes the LEDs on the SF2 to flash alternately for 30 seconds 

GetFiles Downloads any trace files on a File System enabled SF2 

CliCmd Executes serial-port commands over the Ethernet 

Clone Clones another device on the same SCSI bus, use –h <n> to set the target 
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SCSI Id 

GetHotBackupStatus For HotBackup enabled SF2, get the status of the Hot Backup 

TakeHotBackupOffline For HotBackup enabled SF2, control the status of the two cards 

PutHotBackupOnline For HotBackup enabled SF2, control the status of the two cards 

SetHotBackupOnline For HotBackup enabled SF2, control the status of the two cards 

SetHotBackupOffline For HotBackup enabled SF2, control the status of the two cards 

 

 

Option Comment 

--ignore-backup-data Used on backup to prevent writing to the local disk. Acts as a performance 
test of network only. 

-a Set the cmd to be used by CliCmd 

-c Capacity Mode – used by SetCapacity 

-e Emulation Mode – used by SetEmulationMode 

-f Locates the backup / restore file – used by Backup and Restore 

-g New IP Gateway – used by SetIPAddress 

-h Set the target host id for Clone 

-i New IP Address – used by SetIPAddress 

-j New IP Port – used by SetIPAddress 

-k Defines the new size – used by SetSize and SetDriveSize 

-l New IP Mask – used by SetIPAddress 

-m Size Mode – used by SetCapacity 

-p Port – allows Flash2CMD to change the port it uses to connect to the drive 

-q Password – looks up the password set by Flash2GUI for the user 

-r ReadSize – amount of data to put in a network packet on backup or restore 

-s DEPRECATED – used by SetDriveSize for sector count  

-S DEPRECATED – used by SetDriveSize for sector size 

-t Timeout – how long to wait for responses from the drive 

-u Username – as defined by Flash2GUI 

-v Verbose – produces lots of logging 
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Flash2Cmd Errors 

Cannot Connect 
Note that a single SF2 or FF1 will only permit ONE connection at a time. Whilst Flash2GUI is 

connected to a drive, Flash2Cmd will not be able to connect to that same drive. Equally a second 

instance of Flash2GUI on a different PC could not connect to that same drive. 
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Image Manager 

Introduction 
Image Manager is a tool provided to allow the contents of backup images to be edited – either 

extracting files from images or inserting new files to those images. 

Image Manager only works where the image being edited is either a FAT, FAT32 or OS-9 format. OS-

9 is the Microware multi-tasking operating system. 

Usage 
Open up Image Manager using the File -> Image Manager menu option in Flash2GUI. This will open 

the application and display a window which looks very similar to the Windows file manager.  

 

Open a backup image by either selecting the Open icon or File -> Open from the menu. Once you 

open an image you will be presented with a Save dialog. Note that Image Manager edits the image 

file directly on the disk therefore when you open an image, the application immediately tries to copy 

the original image to a new file so that you can make changes without affecting the original image. If 

you don’t want to create a new file then just select the original image file. 

Having opened an image you can add and delete files and directories, etc. 


